Debian -- Security Information -- DSA-4828-1 libxstream-java

Date: unknown

Location: www.debian.org

DSA-4828-1 libxstream-java -- security update

Date Reported:
07 Jan 2021
Affected Packages:
libxstream-java
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2020-26258, CVE-2020-26259.
More information:

Liaogui Zhong discovered two security issues in XStream, a Java library to serialise objects to XML and back again, which could result in the deletion of files or server-side request forgery when unmarshalling.

For the stable distribution (buster), these problems have been fixed in version 1.4.11.1-1+deb10u2.

We recommend that you upgrade your libxstream-java packages.

For the detailed security status of libxstream-java please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libxstream-java