Debian -- Security Information -- DSA-4859-1 libzstd

Date: unknown

Location: www.debian.org

DSA-4859-1 libzstd -- security update

Date Reported:
20 Feb 2021
Affected Packages:
libzstd
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 982519.
More information:

It was discovered that zstd, a compression utility, was vulnerable to a race condition: it temporarily exposed, during a very short timeframe, a world-readable version of its input even if the original file had restrictive permissions.

For the stable distribution (buster), this problem has been fixed in version 1.3.8+dfsg-3+deb10u2.

We recommend that you upgrade your libzstd packages.

For the detailed security status of libzstd please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libzstd