Debian -- Security Information -- DSA-5008-1 node-tar

Date: unknown

Location: www.debian.org

DSA-5008-1 node-tar -- security update

Date Reported:
11 Nov 2021
Affected Packages:
node-tar
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2021-37701, CVE-2021-37712.
More information:

It was discovered that the symlink extraction protections in node-tar, a Tar archives module for Node.js could by bypassed; allowing a malicious Tar archive to symlink into an arbitrary location.

For the stable distribution (bullseye), these problems have been fixed in version 6.0.5+ds1+~cs11.3.9-1+deb11u2.

We recommend that you upgrade your node-tar packages.

For the detailed security status of node-tar please refer to its security tracker page at: https://security-tracker.debian.org/tracker/node-tar