Debian -- Security Information -- DSA-5010-1 libxml-security-java

Date: unknown

Location: www.debian.org

DSA-5010-1 libxml-security-java -- security update

Date Reported:
15 Nov 2021
Affected Packages:
libxml-security-java
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 994569.
In Mitre's CVE dictionary: CVE-2021-40690.
More information:

Apache Santuario - XML Security for Java is vulnerable to an issue where the secureValidation property is not passed correctly when creating a KeyInfo from a KeyInfoReference element. This allows an attacker to abuse an XPath Transform to extract any local .xml files in a RetrievalMethod element.

For the oldstable distribution (buster), this problem has been fixed in version 2.0.10-2+deb10u1.

For the stable distribution (bullseye), this problem has been fixed in version 2.0.10-2+deb11u1.

We recommend that you upgrade your libxml-security-java packages.

For the detailed security status of libxml-security-java please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libxml-security-java