Debian -- Security Information -- DSA-5043-1 lxml

Date: unknown

Location: www.debian.org

DSA-5043-1 lxml -- security update

Date Reported:
12 Jan 2022
Affected Packages:
lxml
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 1001885.
In Mitre's CVE dictionary: CVE-2021-43818.
More information:

It was discovered that lxml, a Python binding for the libxml2 and libxslt libraries, does not properly sanitize its input, which could lead to cross-site scripting.

For the oldstable distribution (buster), this problem has been fixed in version 4.3.2-1+deb10u4.

For the stable distribution (bullseye), this problem has been fixed in version 4.6.3+dfsg-0.1+deb11u1.

We recommend that you upgrade your lxml packages.

For the detailed security status of lxml please refer to its security tracker page at: https://security-tracker.debian.org/tracker/lxml