Debian -- Security Information -- DSA-5132-1 ecdsautils

Date: unknown

Location: www.debian.org

DSA-5132-1 ecdsautils -- security update

Date Reported:
08 May 2022
Affected Packages:
ecdsautils
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2022-24884.
More information:

It was discovered that ecdsautils, a collection of ECDSA elliptic curve cryptography CLI tools verified some cryptographic signatures incorrectly: A signature consisting only of zeroes was always considered valid, making it trivial to forge signatures.

For the oldstable distribution (buster), this problem has been fixed in version 0.3.2+git20151018-2+deb10u1.

For the stable distribution (bullseye), this problem has been fixed in version 0.3.2+git20151018-2+deb11u1.

We recommend that you upgrade your ecdsautils packages.

For the detailed security status of ecdsautils please refer to its security tracker page at: https://security-tracker.debian.org/tracker/ecdsautils