Debian -- Security Information -- DSA-5320-1 tor

Date: unknown

Location: www.debian.org

DSA-5320-1 tor -- security update

Date Reported:
16 Jan 2023
Affected Packages:
tor
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2023-23589.
More information:

A logic error was discovered in the implementation of the SafeSocks option of Tor, a connection-based low-latency anonymous communication system, which did result in allowing unsafe SOCKS4 traffic to pass.

For the stable distribution (bullseye), this problem has been fixed in version 0.4.5.16-1.

We recommend that you upgrade your tor packages.

For the detailed security status of tor please refer to its security tracker page at: https://security-tracker.debian.org/tracker/tor